Strange talent problem


#1

Using Linux Mint 19.2, everything installed and ran perfectly but I’ve noticed a weird problem with an Orc where I visit the weapon trainers (Undercity, TB, Org) and learn a skill, then when I die or exit the game and go back in the skill is unlearned and the shoot/throw skills have been taken away.

I’m using the heirloom gun, was able to equip it and use it for a while, died and upon resurrecting the gun equipment is red and shoot is gone again.


#2

Created a bug report, took some searching to find that is probably better place for it

https://github.com/cmangos/issues/issues/2045


#3

Well nevermind, I’m not giving them a real email and they apparently don’t respect privacy.


#4

Maybe I’m doing something wrong… Hard to believe it would be broken and searched 17 pages of bug reports going back to 2013, when I last tried it around 2014 I swear it used to work.

I’ve even tried clearing cache, rebuilt from scratch, Paladin does the same thing auras don’t work at all and learning any weapon training vanishes upon exit and restart. Is the project really in worse shape now than it was in 2014?


#5

OS - Linux mint 19.2 fully patched
Using WOTLKDB 13992 + updates
no build errors, no errors with db setup

Steps to recreate:
Create an orc warrior
Reach level 20
Visit weapon trainers in TB, Silvermoon, UC, Org
Learn the skills
Walk around and kill stuff, they work fine while logged in
logout/exit/die (die usually for sure)
Upon logging back in the skills are unlearned and repurchasing guns/crossbow/bows/thrown doesn’t relearn the shoot or throw skills.

Also this text was in the server log upon login:
Spell action 3018 not added into button 46 for player Name: player don’t known this spell
…at loading, and will deleted in DB also
Spell action 2764 not added into button 47 for player Name: player don’t known this spell
…at loading, and will deleted in DB also

Seems like there is some script on death or logout that is pulling these skills off the character but I have no idea where to look for that. Very strange issue.